Are projects created with bibisco version 1 compatible with projects created with version 2?

No.

Starting from version 2.0, bibisco is based on a completely different technology (node.js) compared to version 1.0 (java), so the projects created with version 1 of bibisco are not compatible with version 2.

So, if you are at the final chapters of your book on bibisco version 1, we suggest to finish it, and go to version 2 for a new project!